§32a EStG: Steuerberechnung mit Excel® und WENN-Befehlen

Teilen

Die Steuerberechnung des §32a EStG sieht mehrere Steuersätze und mehrere Formeln vor, die für verschiedene Einkommensbereiche gelten. Hierzu geht das Gesetz vom abgerundeten zu versteuernden Jahreseinkommen aus. Zunächst sind die drei Hilfswerte "x", "y" und "z" gemäß der Anweisung des Abs. 1 zu berechnen; anschließend wird für vier Einkommensbereiche jeweils eine separate Formel vorgesehen. Es liegt also eine Staffelrechnung vor. Dies ist für zahlreiche wirtschaftliche Probleme typisch. Das für Staffelrechnungen generell angemessene Lösungsverfahren ist typischerweise der WENN-Befehl. Dieser kleine Beitrag demonstriert die wichtigsten Grundlagen.

Im Haushaltsbegleitgesetz wurde der neue §32a EStG mit folgendem Wortlaut für den Veranlagungszeitraum 2004 veröffentlicht:
§32a Einkommensteuertarif. (1) Die tarifliche Einkommensteuer bemißt sich nach dem zu versteuernden Einkommen. Sie beträgt vorbehaltlich der §§32b, 34, 34b und 34c jeweils in Euro für zu versteuernde Einkommen
1. bis 7.664 Euro (Grundfreibetrag): 0,
2. von 7.665 Euro bis 12.739 Euro: (793,10 * y + 1.600) * y;
3. von 12.740 Euro bis 52.151 Euro: (265,78 * z + 2.405) * z + 1.016;
4. von 52.152 Euro an: 0,45 * x – 8.845;
"y" ist ein Zehntausendstel des 7.664 Euro übersteigenden Teiles des abgerundeten zu versteuernden Einkommens. "z" ist ein Zehntausendstel des 12.739 Euro übersteigenden Teils des auf einen vollen Euro-Betrag abgerundetenm zu versteuernden Einkommens. "x" ist das auf einen vollen Euro-Betrag abgerundete zu versteuernde Einkommen. Der sich egebende Betrag ist auf den nächsten vollen Euro-Betrag abzurunden.

Das Musterbeispiel aus dem Lehrerbereich der BWL CDWie aber setzen wir das in Excel um?

Im Lehrerbereich der BWL CD findet sich die Lösung in Gestalt der Datei "Steuerformel in Excel.xls". Sie sollten diese Datei Ihren Schülern oder Studenten u.U. erst am Schluß der Lehreinheit als Musterlösung zugänglich machen, um den Anreiz, es selbst zu probieren, zu erhalten. Vielfach kommen dabei auch zwei Lösungswege zustande, einer "von unten" und einer "von oben". Der Unterschied zwischen diesen Lösungsalternativen besteht in der Reihenfolge, in der die vier Steuerformeln bearbeitet werden: vom kleinsten oder vom höchsten Grenzwert ausgehend. Stets sind für vier Formeln aber immer nur drei WENN-Befehler erforderlich:

Was steht also in den Zellen der Spalte B?

 

B1 Eingabe des zu berechnenden steuerpflichtigen Jahreseinkommens als Zahleneingabe. Das Feld ist wie in allen meinen Beispielen als Markierung der Eingabemöglichkeit blau, aber die ganze Seite hat als Musterlösung keinen Blattschutz und keine verdeckten Überraschungen 😉

B2 Berechnung des abgerundeten zu versteuernden Jahreseinkommens (Wert x) gemäß §32a Abs. 2:

=GANZZAHL(B1)

B3 Berechnung des Wertes y:

=WENN(B2>7664;(B2-7664)/10000;0)

B4 Berechnung des Wertes z:

=WENN(B2>12739;(B2-12739)/10000;0)

B5 Steuerberechnung, Variante "von unten", d.h., es wird mit dem niedrigsten Grenzwert (7.664 €) begonnen, und die weiteren Grenzwerte werden aufsteigend sukzessive mit WENN-Befehlen abgeprüft:

=WENN(B2<7665;0;WENN(B2<12740;(793,1*B3+1600)*B3;WENN(B2<52152;(265,78*B4+2405)*B4+1016;0,45*B2-8845)))

B7 Steuerberechnung, Variante "von oben", d.h., es wird mit dem höchsten Grenzwert (52.151 €) begonnen, und die weiteren Grenzwerte werden absteigend sukzessive mit WENN-Befehlen abgeprüft:

=WENN(B2>52151;0,45*B2-8845;WENN(B2>12739;(265,78*B4+2405)*B4+1016;WENN(B2>7664;(793,1*B3+1600)*B3;0)))

Die Ergebnisse der Formeln in B5 und B7 sind dabei exakt identisch. Beide Formeln lösen das Problem aber mit einander entgegengesetzten Herangehensweisen. Ach ja, haben Sie sich gewundert, was die farbigen Markierungen in den Formeln bedeuten sollen? Sie können Ihre Schüler ein bißchen drüber rätseln lassen: es ist ein hervorrageder Test, ob die Induktivmethode bei Ihren Lernenden funktioniert.

Selbst schon drauf gekommen?

Na??

Richtig: der Eingangs-Grenzsteuersatz (16%) und der Höchst-Grenzsteuersatz (45%). Dies ohne oder nur mit wenig Hilfe zu erkennen ist ein verschärfter Test im Denken in Analogien ("1600" = 16%; "0,45" = 45%), ein Training, das ich meinen Studenten oder Lehrgangsteilnehmern regelmäßig angedeihen lasse, besonders wenn ich merke, daß die Prozentrechnung nicht beherrscht wird (und Sie ahnen nicht, wie oft das der Fall ist). Übrigens kann man auf diese Art im Unterricht auch gut, den Unterschied zwischen Grenz- und Durchschnittssteuer zu vertiefen, der kaum jemandem wirklich bewußt ist. Natürlich müssen Sie das Thema zuvor eingeführt haben, so daß Sie erwarten können, daß es überhaupt in den Formeln erkannt wird. Aber das ist ein weiteres Thema, für das Sie die Dateien der BWL CD benutzen sollten…

Ach ja, alle Steuerrechnungen auf der BWL CD sind auf CDs ab Herstellungsdatum 23.12.2003 auf das neue Steuerrecht umgestellt.

Links zum ThemaDer Steuertarifrechner der Zingelseite (interner Link)

Ähnliche Themen, die Ihnen gefallen könnten